National

Security Alert: 'High-Risk' Warning For iPhone, iPad And MacBook Users | Details Inside

As per the advisory, the concerned vulnerability is capable of affecting a wide array of Apple software and hardware, including Apple Safari versions prior to 17.4.1, Apple macOS Ventura versions prior to 13.6.6, Apple macOS Sonoma versions prior to 14.4.1, Apple visionOS versions prior to 1.1.1, Apple iOS and iPadOS versions prior to 17.4.1, and Apple iOS and iPadOS versions prior to 16.7.7.

Advertisement

PTI
Representational Image | Photo: PTI
info_icon

Centre on Wednesday has issued a 'high risk' security advisory for users of Apple's iPhones, MacBooks, iPads, and Vision Pro headsets. According to the advisory issued by the Indian Computer Emergency Response Team (CERT-In), a critical vulnerability has been identified in connection to "remote code execution" in various Apple products.

About the security threat

As per the advisory, the concerned vulnerability is capable of affecting a wide array of Apple software and hardware, including Apple Safari versions prior to 17.4.1, Apple macOS Ventura versions prior to 13.6.6, Apple macOS Sonoma versions prior to 14.4.1, Apple visionOS versions prior to 1.1.1, Apple iOS and iPadOS versions prior to 17.4.1, and Apple iOS and iPadOS versions prior to 16.7.7.

Advertisement

As per reports, this technological vulnerability allows remote attackers to execute arbitrary code on the targeted systems.

List of devices under threat

As per the advisory, iPhone XS, iPad Pro 12.9-inch, iPad Pro 10.5-inch, iPad Pro 11-inch, iPad Air, iPad, and iPad mini are susceptible if the devices are running iOS and iPadOS versions prior to 17.4.1.

Moreover, iPhone 8, iPhone 8 Plus, iPhone X, iPad 5th generation, iPad Pro 9.7-inch, and iPad Pro 12.9-inch 1st generation users are also at risk if their devices are not updated to iOS and iPadOS versions 16.7.7 or later.

Besides iPhone and iPad, MacBook users are also requested to update their systems, with macOS Ventura versions prior to 13.6.6 and macOS Sonoma versions prior to 14.4.1 being vulnerable. Moreover, users of the Apple Vision Pro headset should take note of the vulnerability in visionOS versions prior to 1.1.1.

Advertisement

Recommendations to avoid the risk of compromise

According to the official advisory, the users should ensure that Apple iOS, iPadOS, macOS, and visionOS are updated to the latest versions containing security patches.

Here are some other ways to protect the devices from falling prey to the security threat.

Enable Two-Factor Authentication (2FA): 2FA should be implemented to add an extra layer of security against potential credential compromises.

Network Security: Connecting to unsecured or public Wi-Fi networks should be avoided to minimize the risk of unauthorized access.

Download from trusted Sources: Applications should be downloaded from reputable sources like the Apple App Store to mitigate the risk of malware.

Regular backups: Important data should be based up regularly to safeguard against data loss due to security breaches or system failures.

Advertisement

Advertisement

Advertisement

Advertisement

Advertisement

Advertisement